ARIS Community - We Love BPM

ARIS Designer Server Installatio Error

EmmaLv's picture
by Emma Lv in Professional ARIS posted on 2017-04-18

Hi,

I installed ARIS 9.6 designer server on windows 2012 r2 server with MS SQL DB. But the installation failed with unexpected error.

In the umc.log and a few other logs under "work" directory, it shows error message:

2017-04-17 08:27:31,951 [ERROR] (ajp-bio-11082-exec-8) LocalAbstractDao$4 - Failed to initialize persistence layer: {}
java.lang.RuntimeException: com.sag.aris.cip.dbsp.CipTenantDistributionException: could not get a db for tenant(leader did not assign): default

Looks like a database issue? Could someone please help me?

Thanks

Emma

1895 Views
0 Likes
4 Comments
Sorry there are no tags
There are no attachments
Rune Becker posted on 2017-04-18

Dear Emma,

Did you follow the ARIS Server Installation and Administration Guide which requires to initialize your DBMS before running the setup?

As installation failures could have multiple causes, I'd like to recommend to pass your issue to Software AG's Global Support ARIS on our customer portal Empower: https://empower.softwareag.com/eservice.

Besides, ARIS 9.6 is quite old. It had GA mid of 2014. I strongly recommend to use the latest ARIS 9.8 SR7 (as of Dec 2016) or wait until this week ARIS 10.0 becomes available.

Cheers
Rune

Emma Lv posted on 2017-04-18

Rune,

Thanks for replying. Yes i did initialize my DBMS before running the setup. However the error message still points to DB error. "could not get a db for tenant"

Thanks

Emma

Amol Patil posted on 2017-04-18

Hi Emma,

Check the database parameters you passed on to the installation wizard. There must be some wrong value being supplied.

Also on the other hand, try connecting to the MS SQL server using the MS SQL Client installed on ARIS Design Server machine with the ARIS 9 database user.

Regards,

Amol Patil

Emma Lv posted on 2017-04-19

All,

I saw this error in the install logs.  I dont have SQL client installed on ARIS server. But I tried telnet to the DB server and it failed. Will firewall issue cause this kind of error?

4-14-2017 09:59:21   stdout: Executing command "register external service db url="jdbc:sqlserver://server.xxx.com:40005;DatabaseName=ARIS;instance=ARIS_Dev" driverClassName="com.microsoft.sqlserver.jdbc.SQLServerDriver" username="ARIS9" password="A123456!" maxIdle=15 maxActive=100 maxWait=10000 removeAbandoned=false removeAbandonedTimeout=600 logAbandoned=true defaultAutoCommit=false rollbackOnReturn=true host="server.xxx.com""
4-14-2017 09:59:21   stderr: line 1:205 no viable alternative at character 'A'
4-14-2017 09:59:21   stderr: line 1:236 no viable alternative at character '!'
4-14-2017 09:59:21   stderr: line 1:425 mismatched character '<EOF>' expecting '"'
4-14-2017 09:59:21   stderr: Error at line 1 of command file C:\Users\FGLSEA~4\AppData\Local\Temp\{9816D278-3FF9-451D-8E9C-F94ABB58B64F}\{2F95F4D6-FE94-40BE-B916-740F46D7B96D}\DbService.pt: Invalid or erroneous command "register external service db url="jdbc:sqlserver://server.xxx.com:40005;DatabaseName=ARIS;instance=ARIS_DEV" driverClassName="com.microsoft.sqlserver.jdbc.SQLServerDriver" username="ARIS" password="A12345!" maxIdle=15 maxActive=100 maxWait=10000 removeAbandoned=false removeAbandonedTimeout=600 logAbandoned=true defaultAutoCommit=false rollbackOnReturn=true host="server.xxx.com"": line 1:226 missing EQ at 'A12345!'

Thanks

Emma